Question:
Setting up EIGRP on Cisco 1841, all traffic routes through internet connection. I am includinng config. Thanks
2008-06-28 13:47:35 UTC
interface FastEthernet0/0
ip address 10.20.0.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface FastEthernet0/1
ip ddns update hostname pawcatuckoasc.no-ip.biz
ip ddns update pawcatuck
ip address dhcp client-id FastEthernet0/1
ip nat outside
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
encapsulation frame-relay
ip route-cache flow
service-module t1 timeslots 1-24
frame-relay lmi-type ansi
!
interface Serial0/0/0.1 point-to-point
ip address 10.1.1.7 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
frame-relay interface-dlci 200 IETF
!
router eigrp 100
network 10.1.1.7 0.0.0.0
network 10.20.0.1 0.0.0.0
no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
ip route 10.0.0.0 255.255.255.0 10.1.1.3
!
Three answers:
Z
2008-06-28 17:39:35 UTC
What's the question??



network 10.1.1.7 0.0.0.0

network 10.20.0.1 0.0.0.0



the wildcard bits are wrong... should probably be:

network 10.1.1.7 0.0.0.255

network 10.20.0.1 0.0.0.255



With repsect to these two:

ip route 0.0.0.0 0.0.0.0 FastEthernet0/1

ip route 10.0.0.0 255.255.255.0 10.1.1.3



The first, should probably have the next hop address rather than the interface name - though in most cases the interface will work.



The second, you are telling it to route IP addresses of 10.0.0.1 through 10.0.0.255 to 10.1.1.3 --- which is out Serial0/0/0.1







Static routes have a priority level of 1 (on a scale of 0-255 with zero being the best) EIGRP is, I think 30. 0 is a directly connected network.



Int F0/1 has no ip address... maybe add "ip address dhcp"?

=================edit============

give us a "sh int Serial0/0/0.1 point-to-point"

a "sh cdp neigh det " and a sh controller t1

Is your layer 2 Ok?

I can ping your F0/1 today -- you left the name in there. ;)

Second question, do you really need to use eigrp? Do you have multiple path options for reaching these networks?

I mistyped the network statements: network 10.1.1.0 0.0.0.0



But you don't need 255 hosts on a point to point link.
2008-06-29 15:38:42 UTC
Either wildcard mask is fine - all 0's just puts in that specific host, the 0.0.0.255 puts in the whole class C. I assume that 10.1.1.3 is on the other side of this Frame-Relay PVC? And you have EIGRP 100 over there as well? Do a "show ip eigrp neighbor" this will tell you what interfaces you have EIGRP adjacencies across. If this is a hub and spoke frame-relay network you might need to disable split-horizon, for EIGRP go to the p2p sub interface and put:

no ip split-horizon eigrp 100



You should take out the static route to 10.0.0.0/24 because it is likely mucking things up. If you wanted to leave it in as a fail-safe, make it unusually "loose" like:

ip route 10.0.0.0 255.0.0.0 10.1.1.3

Your IP routing table will ALWAYS select the longest match over anything else (excluding PBR, but I doubt that is in play here) even Administrative Distance (AD). So the above static would allow you to use EIGRP and still have a fail-safe in case a network on the far side was accidentally left out of the EIGRP process ... personally I would NOT do that, and remove the 10.0.0.0 static completely.



As an aside, your remote sites on that frame cloud may not reach the Internet if you are using this one router for all Internet. You would want to redistribute that all 0's route into EIGRP or set a default at each spoke. Hope all this helps.
fiedler
2016-12-11 23:52:08 UTC
Setting Up Eigrp


This content was originally posted on Y! Answers, a Q&A website that shut down in 2021.
Loading...