Question:
Cisco 2960 multiple vlan port?
b b
2009-06-10 18:29:59 UTC
Hi,
How to create a port in multiple vlan's on Cisco 2960 switch?
Four answers:
Geek
2009-06-12 09:22:33 UTC
You should explain why do you wan to do that. What do you want to connect to that port. 2 scenarios:

-----------------------------------------------

1 - you want to connect to that port another switch, because you are expanding your network, you have more end users connected etc. In this case, you will connect 2 switches using crossover cable and both you will configure as a trunks, with eventually allowed vlans that you want. But you can skip this portion and in that case all vlans will be allowed, so:



switch#conf t

swtich(config)# int fa0/24

swtich(config)# description CONNECTION TO SWITCH 2

swtich(config)# switchport mode trunk

swtich(config)# switchport trunk encapsulation dot1q

swtich(config)# switchport vlans allowed 10,20,30 // it depens on switch use "?" to find yout correct commands



on the switch 2 the same thing



-----------------------------------------------

2 - if you want to connect regular host to that port, it will not work and it is not recommended way

-----------------------------------------------

3 - maybe you want to connect a router to that port, in that case you willbe able to configure router on the stick, and have subinterfaces. For example let's say you connected router fa0/0 to switch fa0/24 (configured as above trunk), then you can do this on the router:



router# int fa0/0.1

router# encapsulation dot1q 20

router# ip add 172.16.0.1 255.255.255.0



router# int fa0/0.1

router# encapsulation dot1q 30

router# ip add 10.0.0.1 255.0.0.0
Stephen Dugan
2009-06-13 09:57:10 UTC
IF you are trying to create a trunk:



interface f0/1 (or whichever interface in question)

switchport mode trunk



OR



If you are trying to setup a Data and Voice VLAN on the same interface:



Interface f0/1

switchport host

switchport access vlan 2 (this is your data VLAN)

switchport voice vlan 3 (this is your data VLAN)





Hope this helps.
Jason P
2009-06-10 19:34:22 UTC
You should really only be doing that on a trunk port. It would look like so

switchport trunk allowed vlan add 10,11
Chana
2016-03-14 06:03:48 UTC
the dhcp realy command works perfectly fine on packet tracer .. must be something working with your setup ... the confing once again to see it everthing is fine.


This content was originally posted on Y! Answers, a Q&A website that shut down in 2021.
Loading...